
BIMXplorer v1.3.4 installation instructions

BIMXplorer is a plugin to Autodesk 

application that can import IFC

proprietary file format). BIMXplorer 

3D game, either in a regular desktop mode or using the Oculus Rift

Figure 1: BIMXplorer interface. 

The first part of this guide will explain how to install and use the BIMXplorer Revit addin and 

the standalone viewer WITHOUT Oculus Rift

use BIMXplorer together with Oculus

 

1. Setup 

Unzip the downloaded file into a temp dir. 

This will install both the Revit plugin as well as the stand

FYI the software will install into “C:

the plugin (addin-file) will be added to “C:

“C:\ProgramData\Autodesk\Revit

BIMXplorer is targeting OpenGL 4.3 but has a fallback for OpenGL 2.1

version has no Oculus or Vive

problems, make sure that the latest graphics drivers are installed.

On computers with NVIDIA cards, 

Panel. Go to Manage 3D settings

Threaded optimization ON, 

performance". 
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installation instructions and user guide

Autodesk Revit (2016 and 2017) as well as a standalone viewer 

can import IFC-files or load previously saved .grx-

. BIMXplorer makes it possible to “walk around” in a BIM similar to a 

3D game, either in a regular desktop mode or using the Oculus Rift CV1 or HTC Vive 

The first part of this guide will explain how to install and use the BIMXplorer Revit addin and 

the standalone viewer WITHOUT Oculus Rift or HTC Vive. The last part will explain how to 

use BIMXplorer together with Oculus Rift and HTC Vive. 

Unzip the downloaded file into a temp dir. Make sure Revit is not running.

vit plugin as well as the standalone viewer.  
will install into “C:\ProgramData\VIZCODE\BIMXplorer v

file) will be added to “C:\ProgramData\Autodesk\Revit

Revit\Addins\2017”.  

is targeting OpenGL 4.3 but has a fallback for OpenGL 2.1 (however, the fallback 

version has no Oculus or Vive support and has limited graphics quality

problems, make sure that the latest graphics drivers are installed. 

cards, right click on the desktop and launch the 

Manage 3D settings. Make sure Vertical sync is Application Controlled

, and set "Power management mode" to "Prefer maximum 
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and user guide 
as well as a standalone viewer 

files (BIMXplorer’s 

makes it possible to “walk around” in a BIM similar to a 

or HTC Vive HMD. 

 

The first part of this guide will explain how to install and use the BIMXplorer Revit addin and 

part will explain how to 

Make sure Revit is not running. Run setup.exe. 

BIMXplorer v1.3.4” and 

\Addins\2016” and 

(however, the fallback 

support and has limited graphics quality). In case of any 

right click on the desktop and launch the NVIDIA Control 

Vertical sync is Application Controlled, turn 

"Power management mode" to "Prefer maximum 



On computers with integrated AND NVIDIA graphics card, make sure NVIDIA processor is 

chosen as “Preferred graphics processor”.

 

2. Trial period and activation
When BIMXplorer is installed for the first time on a computer 

period. Every time you start BIMXplorer

it with a unique Activation Code. Go to 

info@bimxplorer.com to get information on how t

same as purchasing a “license”)

in Trial Mode by clicking “Trial Run”. 

of BIMXplorer and already hav

to activate the update with the same Activation Code.

Figure 2: BIMXplorer Activation Dialog

 

3. Use the BIMXplorer with Revit
Note: BIMXplorer is not yet “signed” with Autodesk Revit 2017.

the first time after you install BIMXplorer you will be prompted with a dialog similar to the 

following (but with different version nu

 

Figure 3: The “Unsigned Add-In” Dialog in Revit 2017

 

Just click “Always Load”. 
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On computers with integrated AND NVIDIA graphics card, make sure NVIDIA processor is 

raphics processor”. 

Trial period and activation 
When BIMXplorer is installed for the first time on a computer it will begin a 

period. Every time you start BIMXplorer it will display the Activation Dialog until you activate 

it with a unique Activation Code. Go to www.bimxplorer.com

to get information on how to purchase an Activation Code

same as purchasing a “license”). Unless the Trial Period has ended you can start BIMXplorer 

in Trial Mode by clicking “Trial Run”. Note: If you have downloaded and installed an up

BIMXplorer and already have an Activation Code from a previous version, you will be able 

with the same Activation Code. 

 

BIMXplorer Activation Dialog. 

with Revit 
Note: BIMXplorer is not yet “signed” with Autodesk Revit 2017. When starting Revit 2017 for 

the first time after you install BIMXplorer you will be prompted with a dialog similar to the 

following (but with different version number): 

 

In” Dialog in Revit 2017. 
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On computers with integrated AND NVIDIA graphics card, make sure NVIDIA processor is 

it will begin a 30-day trial 

it will display the Activation Dialog until you activate 

www.bimxplorer.com or contact 

o purchase an Activation Code (this is the 

. Unless the Trial Period has ended you can start BIMXplorer 

Note: If you have downloaded and installed an update 

e an Activation Code from a previous version, you will be able 

When starting Revit 2017 for 

the first time after you install BIMXplorer you will be prompted with a dialog similar to the 

 



 

After install, start Revit (2016 or 2017)

“basic” or the “advanced” Revit sample project for the first time in order to just give it a slow 

start). Go to the default 3D-view

External Tools->BIMXplorer v1.

A new window will open and the plugin will extract the model from Revit (the plugin

the geometry that is currently visible so you can isolate or hide stuff if you only want certain 

parts to be shown in the viewer). 

Sometimes the Revit window will put itself *above* the plugin window so you have to 

minimize it, or select the plugin window (BIMXplorer) from the 

After the model has been loaded (progress bar done) 

be placed so that you see the model. Press the [

that all of model is visible (i.e. z

the camera in the middle of the model

 

4. A little bit on navigation

Right Mouse Click: Activate/Deactivate MouseLook

Move Mouse: Look around (when MouseLook is ACTIVE)

w,a,s,d : w=Forward, a=Left, s

q,e: Move camera up/down (when collision detection is NOT active, se

Shift + w,a,s,d : Move faster 

Left Mouse Click: Select object (when 

Esc: Un-select any selected object

h: Hide selected object 

u: Unhide all (show all) 

j: Toggle anti-aliasing (on by default)

F8: Toggle fullscreen 

Space: Place camera so that all of model is visible (Zoom all)

Shift + Space: Place camera in center of model

F4: Toggle Rendering statistics (frame time)

If there are cameras defined in the Revit model, these will now be located at the buttons [1

9] (i.e. press 1 to get to the location defined by the “first” camera). If you hold down [shift] 

while pressing the camera number you will “animate” from you curre

chosen camera position. 

v: Add current viewpoint (accessible
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(2016 or 2017) and load or create a model (perhaps use either the 

“basic” or the “advanced” Revit sample project for the first time in order to just give it a slow 

view and under the Add-Ins tab choose:  

>BIMXplorer v1.3.4. 

A new window will open and the plugin will extract the model from Revit (the plugin

the geometry that is currently visible so you can isolate or hide stuff if you only want certain 

parts to be shown in the viewer).  

Sometimes the Revit window will put itself *above* the plugin window so you have to 

gin window (BIMXplorer) from the Windows taskbar.

After the model has been loaded (progress bar done) the default camera position might not 

be placed so that you see the model. Press the [spacebar] in order to place the camera so 

i.e. zoom all). Hold [Shift] and press [spacebar

the camera in the middle of the model 

A little bit on navigation and interaction: 

: Activate/Deactivate MouseLook 

: Look around (when MouseLook is ACTIVE) 

s=Back, d=Right (When MouseLook is ACTIVE

camera up/down (when collision detection is NOT active, see below)

 

Select object (when MouseLook is NOT active) 

select any selected object 

(on by default) 

: Place camera so that all of model is visible (Zoom all) 

: Place camera in center of model 

: Toggle Rendering statistics (frame time) 

If there are cameras defined in the Revit model, these will now be located at the buttons [1

9] (i.e. press 1 to get to the location defined by the “first” camera). If you hold down [shift] 

while pressing the camera number you will “animate” from you curre

accessible from the button [1-9]) 
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create a model (perhaps use either the 

“basic” or the “advanced” Revit sample project for the first time in order to just give it a slow 

A new window will open and the plugin will extract the model from Revit (the plugin extracts 

the geometry that is currently visible so you can isolate or hide stuff if you only want certain 

Sometimes the Revit window will put itself *above* the plugin window so you have to 

taskbar. 

the default camera position might not 

place the camera so 

spacebar] in order to place 

ACTIVE)  

below) 

If there are cameras defined in the Revit model, these will now be located at the buttons [1-

9] (i.e. press 1 to get to the location defined by the “first” camera). If you hold down [shift] 

while pressing the camera number you will “animate” from you current position to the 



In the Camera Settings Dialog

speed multiplier (how much faster it goes when shift is pressed) as well as 

(when collision detection is acti

 

5. Save File 

When the model has been loaded in 

save a binary file (*.grx) that can be opened in the stand

Revit installed, you can start the stand

desktop) and then choose File

 

6. Collision detection 

There is no collision by default. However, once a model is loaded you can choose 

>Generate Collision Meshes 

When these meshes are generated, 

collision. You can then only “enter” through doors. Also, you need to have something under

"your feet" or you will just fall down. Press "

gravity.  

It’s also possible to only generate collision meshes for 

Topography. For large and complex models this is 

to generate. 

At the Collision menu it is also possible to clear all collision meshes in the scene or 

Add/Remove collision mesh for the selected object

The time taken to calculate collision meshes will vary depending on model complexity. For 

instance, the “Revit basic sample” project as well as the “advanced sample” 

around 5 seconds (using the “Everything” alternative)

there are basically two types of collision meshes 

The triangular meshes are used for

topography and stairs. However, f

generated (this is a much more efficient representation in terms of creation and real

performance). This works well in most of the cases, but for furniture objects

non-convex the “collision volume” becomes very different from the actual geometry

no collision mesh is currently generated for railing objects

If collision meshes are generated before the file is saved

saved (one .cma and one .cms file with the same name as the *.grx file) that contains the 

collision meshes. When you later open the *.grx file (in standalone mode) the collision 

meshes are imported as well (unless yo

new “collision mesh generation step”, just press “
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Camera Settings Dialog (Settings->Camera Settings…) it is possible to change 

(how much faster it goes when shift is pressed) as well as 

(when collision detection is active). 

When the model has been loaded in BIMXplorer you can choose File->Save File

that can be opened in the standalone viewer. That is, without having 

talled, you can start the standalone BIMXplorer (should be a shortcut on the 

File->Open File in order to load a previously saved file (*.grx).

There is no collision by default. However, once a model is loaded you can choose 

 (Everything) in order to activate the collision functionality. 

When these meshes are generated, you can press “c” and then you will have gravity and 

. You can then only “enter” through doors. Also, you need to have something under

"your feet" or you will just fall down. Press "c" again if you want to disable collision and 

generate collision meshes for Floors and Stairs or 

. For large and complex models this is usually preferred because it is 

At the Collision menu it is also possible to clear all collision meshes in the scene or 

Add/Remove collision mesh for the selected object. 

The time taken to calculate collision meshes will vary depending on model complexity. For 

the “Revit basic sample” project as well as the “advanced sample” 

(using the “Everything” alternative). Also, regarding collision detection 

there are basically two types of collision meshes – triangular meshes and convex meshes. 

The triangular meshes are used for the majority of objects, such as 

However, for objects of the type “Furniture” a convex mesh will be 

generated (this is a much more efficient representation in terms of creation and real

This works well in most of the cases, but for furniture objects

the “collision volume” becomes very different from the actual geometry

no collision mesh is currently generated for railing objects. 

If collision meshes are generated before the file is saved (*.grx), two additional files are also 

saved (one .cma and one .cms file with the same name as the *.grx file) that contains the 

collision meshes. When you later open the *.grx file (in standalone mode) the collision 

meshes are imported as well (unless you choose to delete the files) so you don’t have to do a 

new “collision mesh generation step”, just press “c” to activate it. 
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>Camera Settings…) it is possible to change speed, 

(how much faster it goes when shift is pressed) as well as “eye height” 

>Save File in order to 

alone viewer. That is, without having 

BIMXplorer (should be a shortcut on the 

in order to load a previously saved file (*.grx). 

There is no collision by default. However, once a model is loaded you can choose Collision-

in order to activate the collision functionality. 

” and then you will have gravity and 

. You can then only “enter” through doors. Also, you need to have something under 

" again if you want to disable collision and 

or Floors, Stairs and 

preferred because it is much faster 

At the Collision menu it is also possible to clear all collision meshes in the scene or 

The time taken to calculate collision meshes will vary depending on model complexity. For 

the “Revit basic sample” project as well as the “advanced sample” project will take 

Also, regarding collision detection 

triangular meshes and convex meshes. 

 walls, slabs, roofs, 

a convex mesh will be 

generated (this is a much more efficient representation in terms of creation and real-time 

This works well in most of the cases, but for furniture objects that are very 

the “collision volume” becomes very different from the actual geometry. Also, 

(*.grx), two additional files are also 

saved (one .cma and one .cms file with the same name as the *.grx file) that contains the 

collision meshes. When you later open the *.grx file (in standalone mode) the collision 

u choose to delete the files) so you don’t have to do a 



7. Materials and links 

There is (basic) support for most of the Revit materials (i.e. color or diffuse texture

color, as well as transparency and simple cubemap reflections). The lighting used

is fairly simple, but can be enhanced with 

provides “contact shadows” and gives a much better “depth” to the image

You can enable SSAO and Sky Rendering

If your model has linked files you can control the visibility of these with 

Visibility. Tick or un-tick to hide/show links.

Figure 4: SSAO off (left) as well as on (right) for two different BIMs. 

 

8. Use the “Standalone viewer”

Start BIMXplorer v1.3.4 (either from the 

Choose File->Open File to load a previously saved .grx

IFC 2x3 file. It is also possible to import 

interaction is the same as for the Revit plugin (see above)

also choose (Import And) Append

Append will add the model to the current scene

current scene and also make it 

Visibility...  

In summary, Import And Append

IFC-files, each one representing a different discipline (i.e. Architectural, Structural, HVAC, 

etc.). The visibility of each discipline

Visbility...) 
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here is (basic) support for most of the Revit materials (i.e. color or diffuse texture

as well as transparency and simple cubemap reflections). The lighting used

fairly simple, but can be enhanced with Screen-Space Ambient Occlusion (SSAO)

and gives a much better “depth” to the image

and Sky Rendering under Settings->Graphics Settings...

If your model has linked files you can control the visibility of these with 

tick to hide/show links. 

: SSAO off (left) as well as on (right) for two different BIMs.  

alone viewer” 

(either from the Start menu or from the shortcut on the desktop). 

to load a previously saved .grx-file or File->Import IFC

It is also possible to import 3ds files exported from SketchUp. 

is the same as for the Revit plugin (see above). For .grx files and IFC

Append (IFC) or (Import And) Append (IFC) as Link

will add the model to the current scene; Append as Link will add the model to the 

current scene and also make it possible to hide/show sub-models under 

Append IFC as Link will make it possible to load several different 

files, each one representing a different discipline (i.e. Architectural, Structural, HVAC, 

discipline can then be controlled individually (
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here is (basic) support for most of the Revit materials (i.e. color or diffuse texture, tint 

as well as transparency and simple cubemap reflections). The lighting used by default 

Space Ambient Occlusion (SSAO). SSAO 

and gives a much better “depth” to the image (see Figure 4).  

>Graphics Settings... 

If your model has linked files you can control the visibility of these with Visibility->Links 

 

 

tart menu or from the shortcut on the desktop). 

Import IFC to import an 

files exported from SketchUp. Navigation and 

For .grx files and IFC-files you can 

as Link.  

will add the model to the 

ls under Visibility->Links 

will make it possible to load several different 

files, each one representing a different discipline (i.e. Architectural, Structural, HVAC, 

can then be controlled individually (Visibility->Links 



8.1 IFC Import options 

Upon selecting an IFC-file (using any of the Import IFC alternatives)

show: 

For normal IFC-files, choose In

large IFC-files exceeding the 

Property Sets for all objects in the scene, tick 

might lead to a slower import process.

 

9. Color-coding different links

If you have links in the Revit file or if you import several IFC

Append IFC As Link you can override the default color 

Visibility->Links Visibility... and select any link and right

select a color for all the objects in that link. This is useful during design review session to 

separate objects by discipline.

Figure 5: Overriding the object color in links
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(using any of the Import IFC alternatives), the following dialog will 

 

choose In-memory. The Database alternative is mainly if we have

files exceeding the computer’s internal memory. If you also want 

Property Sets for all objects in the scene, tick “Import Property Sets”. It is optional 

might lead to a slower import process. 

coding different links 

If you have links in the Revit file or if you import several IFC-files using 

you can override the default color of the objects in a certain link. Go to 

and select any link and right-click and chose Override Color...

select a color for all the objects in that link. This is useful during design review session to 

separate objects by discipline. 

 

Overriding the object color in links. 
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, the following dialog will 

. The Database alternative is mainly if we have very 

. If you also want to extract the 

It is optional because it 

files using File->Import and 

the objects in a certain link. Go to 

Override Color... to 

select a color for all the objects in that link. This is useful during design review session to 



10. Fixing “broken” IFC geometry

In some cases the IFC-geometry can have 

Figure 6: IFC object with “broken” geometry

 

To fix this, select the object and choose 

IFC geometry). The result is shown in Figure 

Figure 7: IFC object after correcting the 

 

For files with many “broken” objects you can choose

(for IFC geometry) in order to process all objects in the file
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geometry 

geometry can have “flipped faces” as illustrated in Figure 

 

geometry. 

To fix this, select the object and choose Geometry->Fix Normals On Selected Objects (for 

. The result is shown in Figure 7. 

 

after correcting the geometry. 

objects you can choose Geometry->Fix Normals On 

in order to process all objects in the file. 
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as illustrated in Figure 6. 

>Fix Normals On Selected Objects (for 

>Fix Normals On All Objects 



11. Display object properties

Information->Selection Info will display the 

its properties in the dialog, as shown in Figure 

Figure 8: Displaying object properties (Property Sets)

 

12. Using BIMXplorer with a VR headset

BIMXplorer has support for both Oculus Rift CV1 and HTC Vive. However, before using 

BIMXplorer with either one 

properly (i.e. install the Oculus Software and/or 

regarding tracker positioning, 

12.1 Using the Oculus Rift 

Note: As BIMXplorer is not “signed” with Oculus it is required to tell Oculus to allow 

“Unknown Sources”. Start the Oculus software and go to Settings

Unknown Sources. 

It is usually best to have the Oculus software running and the 

before starting BIMXplorer. 

If the Oculus is connected when BIMXplorer is 

plugin) it will automatically enter “Oculus mode”. 

settings) is functional as before but the navigation interface is different.

To control movement we are using the 

in the direction you look, and ”

navigation speed. If collision meshes are generated, you can press “

activate gravity and collision (recommended).

Settings… (recommended). When using the Oculus it is recommended to stand up

height” is taken from the Oculus Settings (changing the “Eye height” parameter in 

BIMXplorer has no effect in “Oculus Mode”). To calibrate the 

Settings->Devices->Sensor->Reset Default View
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Display object properties 

will display the Properties Dialog. Selecting an

, as shown in Figure 8. 

 

Displaying object properties (Property Sets). 

. Using BIMXplorer with a VR headset 

BIMXplorer has support for both Oculus Rift CV1 and HTC Vive. However, before using 

BIMXplorer with either one of these systems you will first need to setup each system 

properly (i.e. install the Oculus Software and/or Steam VR and also follow the setup guides 

, calibration, room setup, etc.). 

Rift without Oculus Touch: 

is not “signed” with Oculus it is required to tell Oculus to allow 

Start the Oculus software and go to Settings->General and enable 

It is usually best to have the Oculus software running and the Oculus window minimized 

 

If the Oculus is connected when BIMXplorer is started (either as standalone or as a Revit 

plugin) it will automatically enter “Oculus mode”. The menu system (i.e. file loading and 

before but the navigation interface is different. 

control movement we are using the Oculus Remote (Figure 9). ”Up” will take you forward 

, and ”Down” backward. Right and Left will increase/decrease the 

collision meshes are generated, you can press “c” on the keyboard 

activate gravity and collision (recommended). Also, enable SSAO under Settings

When using the Oculus it is recommended to stand up

height” is taken from the Oculus Settings (changing the “Eye height” parameter in 

BIMXplorer has no effect in “Oculus Mode”). To calibrate the Oculus eye height, go to 

>Reset Default View.  
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. Selecting an object will show 

BIMXplorer has support for both Oculus Rift CV1 and HTC Vive. However, before using 

you will first need to setup each system 

Steam VR and also follow the setup guides 

is not “signed” with Oculus it is required to tell Oculus to allow 

>General and enable 

window minimized 

alone or as a Revit 

The menu system (i.e. file loading and 

” will take you forward 

Right and Left will increase/decrease the 

on the keyboard to 

enable SSAO under Settings->Graphics 

When using the Oculus it is recommended to stand up. The “eye-

height” is taken from the Oculus Settings (changing the “Eye height” parameter in 

Oculus eye height, go to 



Figure 9: The Oculus Rift navigation interface.

 

12.2 Using HTC Vive: 

Make sure SteamVR is installed. Plugin all the HTC Vive cables. 

VR button in the top-right corner

connected: 

Figure 10: Activating VR in Steam. 

Now, start BIMXplorer. Load any previously saved model. 

NAVIGATION – FLY MODE: 

Pressing ”Up” on the ”touchpad” on any of the two controllers 

direction you look, and ”Down” backward.

time will make you go faster. Same for ”Down”.

possible to use ”Teleport mode

can press ”c” on the keyboard to activate 
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navigation interface. 

Make sure SteamVR is installed. Plugin all the HTC Vive cables. Start Steam

right corner of the Steam interface and make sure all your devices gets 

 

Load any previously saved model.  

” on the ”touchpad” on any of the two controllers will take you forward 

and ”Down” backward. Pressing ”Up” on both controllers at the same 

time will make you go faster. Same for ”Down”. This is the default ”Fly mode

Teleport mode” (see below). If you have collision meshes generated, you 

” on the keyboard to activate gravity and collision detection.´ 
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Start Steam. Then press the 

of the Steam interface and make sure all your devices gets 

will take you forward in the 

controllers at the same 

ly mode”. It is also 

If you have collision meshes generated, you 

 



Figure 11: Vive controller touchpad and trigger

NAVIGATION – TELEPORT MODE

Figure 12: Teleport Mode navigation
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controller touchpad and trigger. 

MODE: 

Teleport Mode navigation. 
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TOOLS: 

Assuming the left controller was the first one you ”activated”, this will be you 

MenuController. The right one will be your 

With no tool active when you start (you’re in 

trigger on the right controller will 

instance, you can use this ray

model on the computer screen.

When pressing the trigger on the left controller a ”tools

from the right controller, you can now select a tool

VR will happen when you RELEASE the trigger.

Figure 13: Selecting a tool from the Tools Palette

After you have selected a tool you can release the trigger on the left controller to hide the 

tools-palette. 

There are currently three (3) tools implemented (the bird icon is used to go back to 

navigation mode): 

 The Measure Tool:

With this tool active you will get a new panel on the right controller displaying your currently 

measured distance. Press and release the trigger on the right controller to select two points 

in the scene. A red “distance ray” will be rendered and th

Select two different points to measure a new distance.

When you are “in a tool” you can still navigate forward/back with the left controller

To “exit” from a tool, select either another tool on the “Tools

enter “navigation mode” (which was active when you started).
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Assuming the left controller was the first one you ”activated”, this will be you 

. The right one will be your ToolsController.  

With no tool active when you start (you’re in navigation mode when you start

trigger on the right controller will display a ”ray-pointer”. During design review sessions, for 

instance, you can use this ray-pointer to guide other people that are looking at the same 

model on the computer screen. 

pressing the trigger on the left controller a ”tools-palette” will show up. Using the ray 

from the right controller, you can now select a tool. Similar to a mouse-click, your 

VR will happen when you RELEASE the trigger. 

 

tool from the Tools Palette. 

After you have selected a tool you can release the trigger on the left controller to hide the 

There are currently three (3) tools implemented (the bird icon is used to go back to 

Tool:  

With this tool active you will get a new panel on the right controller displaying your currently 

measured distance. Press and release the trigger on the right controller to select two points 

in the scene. A red “distance ray” will be rendered and the distance displayed on the panel. 

Select two different points to measure a new distance. 

When you are “in a tool” you can still navigate forward/back with the left controller

To “exit” from a tool, select either another tool on the “Tools-palette” or the 

enter “navigation mode” (which was active when you started). 
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Assuming the left controller was the first one you ”activated”, this will be you 

when you start), pressing the 

. During design review sessions, for 

pointer to guide other people that are looking at the same 

palette” will show up. Using the ray 

click, your ”click” in 

After you have selected a tool you can release the trigger on the left controller to hide the 

There are currently three (3) tools implemented (the bird icon is used to go back to 

With this tool active you will get a new panel on the right controller displaying your currently 

measured distance. Press and release the trigger on the right controller to select two points 

e distance displayed on the panel. 

When you are “in a tool” you can still navigate forward/back with the left controller 

palette” or the “bird-icon” to 



 The Perpendicular Measure Tool:

This tool is similar as the Measure Tool, but you only select one point. Based on the 

orientation of the surface you hit (the normal of the 

This ray is perpendicular to the surface and will extend until it hits some other surface in the 

3D-model. The length of the ray will be displayed on the panel. This tool is useful for 

measuring the width of corrido

 The Select Tool: 

With this tool you can select any object in the 3D

Figure 14: Using the Select Tool to display object properties

If an object has more than 

left/right on the right controller. On each “page” a single property set will be displayed.

 

12.3 Using Oculus Rift with Oculus Touch

In order to use the Oculus Touch controllers in BIMXplorer we ar

advantage of SteamVR. In order to activate that support, go to 

tick “Use SteamVR for Oculus”. Note that you need to restart BIMXplorer for this setting to 

take effect. 
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The Perpendicular Measure Tool: 

This tool is similar as the Measure Tool, but you only select one point. Based on the 

orientation of the surface you hit (the normal of the surface), a new ray will be constructed. 

This ray is perpendicular to the surface and will extend until it hits some other surface in the 

model. The length of the ray will be displayed on the panel. This tool is useful for 

measuring the width of corridors or a distance from the floor to the ceiling.

 

With this tool you can select any object in the 3D-model and display all of its 

 

Using the Select Tool to display object properties. 

If an object has more than one property sets, you can cycle through them by pressing 

left/right on the right controller. On each “page” a single property set will be displayed.

Using Oculus Rift with Oculus Touch: 

In order to use the Oculus Touch controllers in BIMXplorer we ar

In order to activate that support, go to Settings->VR Settings...

tick “Use SteamVR for Oculus”. Note that you need to restart BIMXplorer for this setting to 
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This tool is similar as the Measure Tool, but you only select one point. Based on the 

surface), a new ray will be constructed. 

This ray is perpendicular to the surface and will extend until it hits some other surface in the 

model. The length of the ray will be displayed on the panel. This tool is useful for 

rs or a distance from the floor to the ceiling. 

model and display all of its “property sets”: 

one property sets, you can cycle through them by pressing 

left/right on the right controller. On each “page” a single property set will be displayed. 

In order to use the Oculus Touch controllers in BIMXplorer we are currently taking 

>VR Settings... and 

tick “Use SteamVR for Oculus”. Note that you need to restart BIMXplorer for this setting to 



Figure 15: The VR Settings Dialog. 

However, if you don’t have the Oculus Touch controllers you should 

through SteamVR because of 

lower performance. 

Make sure both Oculus Runtime AND 

Steam. Then press the VR button in the top

sure all your devices gets connected:

Figure 16: Activating VR in Steam with Oculus Rift and Oculus Touch

Now, start BIMXplorer. Load any previously saved model.

NAVIGATION: 

Pressing the joystick ”Up” on any of the two controllers 

direction you look, and ”Down” backward.

the same time will make you go faster. Same for ”Down”.

way as with the HTC Vive (se previous section)

can press ”c” on the keyboard to activate gravity and collision detection.´

Figure 17: Oculus Touch controllers 
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However, if you don’t have the Oculus Touch controllers you should NOT

because of lack of interaction with the Oculus Remote as well as 

both Oculus Runtime AND SteamVR is installed. Plugin all the Oculus

press the VR button in the top-right corner of the Steam interface and make 

sure all your devices gets connected: 

 

with Oculus Rift and Oculus Touch. 

Load any previously saved model. 

” on any of the two controllers will take you forward 

, and ”Down” backward. Pressing the joystick ”Up” on 

the same time will make you go faster. Same for ”Down”. Teleport Mode works in the same 

way as with the HTC Vive (se previous section) If you have collision meshes generated, you 

” on the keyboard to activate gravity and collision detection.´ 

 

 and trigger. 
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NOT use the Oculus 

lack of interaction with the Oculus Remote as well as slightly 

Oculus cables. Start 

of the Steam interface and make 

will take you forward in the 

”Up” on both controllers at 

Teleport Mode works in the same 

If you have collision meshes generated, you 

 



TOOLS: 

Assuming the left controller was the first one you ”activated”, this will be you 

MenuController. The right one will be your 

With no tool active when you start (you’re in navigation mode when you start), 

trigger on the right controller will display a ”ray

instance, you can use this ray

model on the computer screen.

When pressing the trigger on the left controller a ”to

from the right controller, you can now select a tool. 

VR will happen when you RELEASE the trigger.

Figure 18: Selecting a tool from the Tools Palette

After you have selected a tool you can release the trigger on the left controller to hide the 

tools-palette. 

There are currently three (3) tools implemented (the bird icon is used to go back to 

navigation mode): 

 The Measure Tool:

With this tool active you will get a 

measured distance. Press and release the trigger on the right controller to select two points 

in the scene. A red “distance ray” will be rendered and the distance displayed on the panel. 

Select two different points to measure a new distance.
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Assuming the left controller was the first one you ”activated”, this will be you 

. The right one will be your ToolsController.  

With no tool active when you start (you’re in navigation mode when you start), 

right controller will display a ”ray-pointer”. During design review sessions, for 

instance, you can use this ray-pointer to guide other people that are looking at the same 

model on the computer screen. 

When pressing the trigger on the left controller a ”tools-palette” will show up. Using the ray 

from the right controller, you can now select a tool. Similar to a mouse-click, your 

VR will happen when you RELEASE the trigger. 

 

Selecting a tool from the Tools Palette. 

selected a tool you can release the trigger on the left controller to hide the 

There are currently three (3) tools implemented (the bird icon is used to go back to 

The Measure Tool:  

With this tool active you will get a new panel on the right controller displaying your currently 

measured distance. Press and release the trigger on the right controller to select two points 

in the scene. A red “distance ray” will be rendered and the distance displayed on the panel. 

o different points to measure a new distance. 
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Assuming the left controller was the first one you ”activated”, this will be you 

With no tool active when you start (you’re in navigation mode when you start), pressing the 

. During design review sessions, for 

pointer to guide other people that are looking at the same 

palette” will show up. Using the ray 

click, your ”click” in 

 

selected a tool you can release the trigger on the left controller to hide the 

There are currently three (3) tools implemented (the bird icon is used to go back to 

new panel on the right controller displaying your currently 

measured distance. Press and release the trigger on the right controller to select two points 

in the scene. A red “distance ray” will be rendered and the distance displayed on the panel. 



Figure 19: Using the Measure Tool. 

When you are “in a tool” you can still navigate forward/back with the left controller

To “exit” from a tool, select either another tool on the “Tools

enter “navigation mode” (which was active when you started).

 

 The Perpendicular Measure Tool:

This tool is similar as the Measure Tool, but you only select one point. Based on the 

orientation of the surface you hit (the normal of the surfac

This ray is perpendicular to the surface and will extend until it hits some other surface in the 

3D-model. The length of the ray will be displayed on the panel. This tool is useful for 

measuring the width of corridors or 

Figure 20: Using the Perpendicular Measure Tool
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When you are “in a tool” you can still navigate forward/back with the left controller

To “exit” from a tool, select either another tool on the “Tools-palette” or the 

enter “navigation mode” (which was active when you started). 

The Perpendicular Measure Tool: 

This tool is similar as the Measure Tool, but you only select one point. Based on the 

orientation of the surface you hit (the normal of the surface), a new ray will be constructed. 

This ray is perpendicular to the surface and will extend until it hits some other surface in the 

model. The length of the ray will be displayed on the panel. This tool is useful for 

measuring the width of corridors or a distance from the floor to the ceiling.

 

Using the Perpendicular Measure Tool. 
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When you are “in a tool” you can still navigate forward/back with the left controller 

palette” or the “bird-icon” to 

This tool is similar as the Measure Tool, but you only select one point. Based on the 

e), a new ray will be constructed. 

This ray is perpendicular to the surface and will extend until it hits some other surface in the 

model. The length of the ray will be displayed on the panel. This tool is useful for 

a distance from the floor to the ceiling. 



 The Select Tool: 

With this tool you can select any object in the 3D

Figure 21: Using the Select Tool to display 

If an object has more than one property sets, you can cycle through them by pressing 

left/right on the right controller. On each “page” a single property set will be displayed.
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With this tool you can select any object in the 3D-model and display all of its “property sets”:

 

Using the Select Tool to display object properties. 

If an object has more than one property sets, you can cycle through them by pressing 

left/right on the right controller. On each “page” a single property set will be displayed.
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model and display all of its “property sets”: 

If an object has more than one property sets, you can cycle through them by pressing 

left/right on the right controller. On each “page” a single property set will be displayed. 


